首页 > Joomla > Error :the XML response that was returned from the server is invalid.

Error :the XML response that was returned from the server is invalid.

2010年5月21日

今天得到一个Joomla  1.5.17 的付费网店模板,使用Quickstart进行安装,一切顺利,可以到了第五步,安装示例数据时出错了,Firefox弹出一个对话框说:Error :the XML response that was returned from the server is invalid.  试了很多方法都不能解决,想到以前安装 VirtueMart 时使用 Firefox 也出现过一些莫名其妙的错误,于是使用遨游来进行安装,结果是一切顺利!哎,都是Firefox 惹的祸 (Firefox版本为3.63)。后来搜索了Joomla官方论坛,发现了相似的错误,别人也是换其它浏览器解决的,一并贴上。

Ok, I was having this exact same problem but have fixed it now. Here are the details for the next guy.

I installed a Joomla site (1.5.7) a few days ago. Worked perfectly. Went to install another one today, and boom, no go. Kept getting the errors:
I didn’t change anything on the server config wise, same php 5, mysql 5, etc. exact same everything. So I spent hours trying different permissions, with/without configuration.php, blank, writable etc. every suggestion I saw online. Then, started to think, what did I change, what could possibly have been the issue?

Well, between installing the first site a few days ago, and the site today, I installed a couple of Firefox plugins and updated a few. So I tried to install using Safari instead. Worked perfectly.

So, somewhere there seems to be a conflict with a Firefox plugin and installing Joomla. Because I don’t like to leave a question unsolved, I went through the extensions I had installed recently and figured out which one it was. Y!Slow from Yahoo. Uninstalled that, restarted Firefox and installs worked again. Now it may not be just Y!Slow, it seems to actually be that the cookies weren’t being passed correctly.

声明:本站遵循 署名-非商业性使用-相同方式共享 3.0 共享协议. 转载请注明转自 执子之手与子偕老
  1. 本文目前尚无任何评论.
  1. 本文目前尚无任何 trackbacks 和 pingbacks.